How to update Ruby to 2.3.1 on macOS Sierra ?

macOS Sierra 上的ruby版本为 ruby 2.0.0p648, 但是在安装cocoapods的时候,提示 activesupport requires Ruby version >= 2.2.2。 有两种办法安装新版本的ruby: 一: 使用Homebrew来安装,如果没有安装Homebrew的话,首先安装 安装完成之后在终端执行如下命令来安装ruby 安装完成之后,需要添加ruby到环境变量即可。   二:使用rvm(Ruby Version Manager,Ruby版本管理器)进行安装,推荐使用这种方法。首先安装rvm: 测试是否安装正常 然后安装ruby 如果需要列出所有安装的版本,或者卸载一个已安装ruby版本:  

Symfony 3.0 attribute 'factory-service' and 'factory-method' is not allowed

最近使用 Symfony3.0 开发项目的时候,发现在之前的 Symfony 2.x 版本的,在注入服务的时候可以使用下列方法: 结果到了使用 Symfony 3.0 的时候,使用同样的方法进行注入的时候,会报一下错误: 结果仔细看文档,才发现 3.0版本已经没有这种写法了,需要做如下调整 :  

在 SpringMVC 中扩展MyBatis 的 SqlSessionFactoryBean使其支持 Apache Ant 路径匹配的TypeAliases 配置方式

软件包环境: mybatis-spring-1.2.3.jar mybatis-3.3.0.jar spring webmvc 4.1.6 MyBatis 的别名配置文件入口只有能有一个,而且必须写在这个文件或者添加包的扫描路径然后使用注解,很难维护,要想web项目模块间的依赖,维护更是十分困难。所以重写了SqlSessionFactoryBean. 中间的很多代码是直接复制MyBatis 的 SqlSessionFactoryBean类的源码,然后添加自己的扩展代码,整合MyBatis和SpringMVC的时候,配置文件中只需要这样配置就可以了, 下面的截图是我项目中的代码目录结构,bundle下面的都是按模块划分, 直接上代码:  

How to setup doctrine table prefix in symfony2

首先创建一个 bundle,

php app/console generate:bundle --namespace=Vshop/Bundle/CoreBundle --format=xml

 
然后打开 CoreBundle 里面的这个 service 文件 src/Vshop/Bundle/CoreBundle/Resources/config/services.xml
我的项目配置文件进行了分割,方便以后的管理,目录结构如下......

Symfony2 开发常用命令

1.使用composer包管理工具进行安装. 2. 创建一个Bundle 3. 安装资源文件到web目录下 4.清除cache: 5.生成数据库 6.Doctrine能够按照我们的定义来生成对应的类 7.Doctrine来生成数据表:

Page 2 of 10123...6...>>